adapter upgrade, nhincproxy missing

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

adapter upgrade, nhincproxy missing

dtrepanier
I am upgrading an existing 3.3 adapter to 4.6, and I noticed the following imports can't be resolved and the corresponding code below to not compile.  Any help would be appreciated.  Thanks, Dave


import gov.hhs.fha.nhinc.nhincproxydocquery.NhincProxyDocQuery;
import gov.hhs.fha.nhinc.nhincproxydocquery.NhincProxyDocQueryPortType;
import gov.hhs.fha.nhinc.nhincproxydocretrieve.NhincProxyDocRetrieve;
import gov.hhs.fha.nhinc.nhincproxydocretrieve.NhincProxyDocRetrievePortType;


          //------------------------------------
          // set up to call the web Q4D service
          //------------------------------------
            NhincProxyDocQueryPortType port;
            NhincProxyDocQuery service = new NhincProxyDocQuery();
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: adapter upgrade, nhincproxy missing

Tabassum
Administrator
Hi,

A lot of code changes have happened since 3.3 to 4.6. You would need to implement the following interfaces for your adapter:
gov.hhs.fha.nhinc.docquery.adapter.proxy (~\Product\Production\Services\DocumentQueryCore)
gov.hhs.fha.nhinc.docretrieve.adapter.proxy(~\Product\Production\Services\DocumentRetrieveCore)

Please refer to these wiki for more information on writing adapters:

https://connectopensource.atlassian.net/wiki/display/CONNECTWIKI/Create+a+Doc+Repository+adapter

https://connectopensource.atlassian.net/wiki/display/CONNECT4/Adapter+Changes+Required+to+Use+CONNECT+4
Thanks
Tabassum
(CONNECT Product Team Member)
Loading...