Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

classic Classic list List threaded Threaded
22 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

richersoon
Hi,

I am getting error when I trying to install CONNECT in Jboss 7.1.1:

Caused by: java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent from [Module "deployment.CONNECT-JB7.ear.CONNECTAdminGUI-4.5.0-SNAPSHOT.war:main" from Service Module Loader]
        at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
        at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
        ... 15 more

06:59:07,483 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS015871: Deploy of deployment "mysql-connector-java-5.1.10.jar" was rolled back with no failure message
06:59:07,487 INFO  [org.jboss.as.server] (DeploymentScanner-threads - 2) JBAS015870: Deploy of deployment "CONNECT-JB7.ear" was rolled back with failure message {"JBAS014671: Failed services" => {"jboss.deployment.subunit.\"CONNECT-JB7.ear\".\"CONNECTGatewayWeb-4.5.0-SNAPSHOT.war\".POST_MODULE" => "org.jboss.msc.service.StartException in service jboss.deployment.subunit.\"CONNECT-JB7.ear\".\"CONNECTGatewayWeb-4.5.0-SNAPSHOT.war\".POST_MODULE: Failed to process phase POST_MODULE of subdeployment \"CONNECTGatewayWeb-4.5.0-SNAPSHOT.war\" of deployment \"CONNECT-JB7.ear\"","jboss.deployment.subunit.\"CONNECT-JB7.ear\".\"CONNECTAdapterWeb-4.5.0-SNAPSHOT.war\".POST_MODULE" => "org.jboss.msc.service.StartException in service jboss.deployment.subunit.\"CONNECT-JB7.ear\".\"CONNECTAdapterWeb-4.5.0-SNAPSHOT.war\".POST_MODULE: Failed to process phase POST_MODULE of subdeployment \"CONNECTAdapterWeb-4.5.0-SNAPSHOT.war\" of deployment \"CONNECT-JB7.ear\"","jboss.deployment.subunit.\"CONNECT-JB7.ear\".\"CONNECTAdminGUI-4.5.0-SNAPSHOT.war\".POST_MODULE" => "org.jboss.msc.service.StartException in service jboss.deployment.subunit.\"CONNECT-JB7.ear\".\"CONNECTAdminGUI-4.5.0-SNAPSHOT.war\".POST_MODULE: Failed to process phase POST_MODULE of subdeployment \"CONNECTAdminGUI-4.5.0-SNAPSHOT.war\" of deployment \"CONNECT-JB7.ear\"","jboss.deployment.subunit.\"CONNECT-JB7.ear\".\"CONNECTCommonWeb-4.5.0-SNAPSHOT.war\".POST_MODULE" => "org.jboss.msc.service.StartException in service jboss.deployment.subunit.\"CONNECT-JB7.ear\".\"CONNECTCommonWeb-4.5.0-SNAPSHOT.war\".POST_MODULE: Failed to process phase POST_MODULE of subdeployment \"CONNECTCommonWeb-4.5.0-SNAPSHOT.war\" of deployment \"CONNECT-JB7.ear\""}}
06:59:07,571 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015877: Stopped deployment mysql-connector-java-5.1.10.jar in 72ms
06:59:07,580 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015877: Stopped deployment CONNECTGatewayWeb-4.5.0-SNAPSHOT.war in 81ms
06:59:07,581 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015877: Stopped deployment CONNECTCommonWeb-4.5.0-SNAPSHOT.war in 81ms
06:59:07,584 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015877: Stopped deployment CONNECTAdminGUI-4.5.0-SNAPSHOT.war in 84ms
06:59:07,583 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-1) JBAS015877: Stopped deployment CONNECTAdapterWeb-4.5.0-SNAPSHOT.war in 83ms
06:59:07,703 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015877: Stopped deployment CONNECT-JB7.ear in 204ms
06:59:07,704 INFO  [org.jboss.as.controller] (DeploymentScanner-threads - 2) JBAS014774: Service status report

attached is the full server log..

thanks,
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

Naresh Subramanyan
We are currently not supporting AdminGUI part of the CONNECT ear, try deploying the AdminGUI war separately.

Thanks,
Naresh

Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

richersoon
Is there any modules required to run the AdminGUI separately?

Below are the valid modues:

AD,PD,DQ,DR,DS
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

Naresh Subramanyan
No, for core SOAP services (AD, PD, DQ, DR, DS, X12) it’s not dependent on any other modules.

Thanks,
Naresh
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

richersoon
When I deployed the AdminGUI in jboss, and then I accessed it in http://localhost:8080/CONNECTAdminGUI

It says error HTTP Status 404..

Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

Naresh Subramanyan
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

richersoon
In reply to this post by richersoon
Here's the excerpt of the server.log

09:38:13,156 INFO  [org.hibernate.impl.SessionFactoryObjectFactory] (MSC service thread 1-1) Not binding factory to JNDI, no JNDI name configured
09:38:13,431 INFO  [org.springframework.web.context.ContextLoader] (MSC service thread 1-1) Root WebApplicationContext: initialization completed in 4212 ms
09:38:13,669 INFO  [org.apache.myfaces.config.DefaultFacesConfigurationProvider] (MSC service thread 1-1) Reading standard config META-INF/standard-faces-config.xml
09:38:14,264 INFO  [org.apache.myfaces.config.DefaultFacesConfigurationProvider] (MSC service thread 1-1) Reading config /WEB-INF/faces-config.xml
09:38:18,435 INFO  [org.apache.myfaces.config.DefaultFacesConfigurationProvider] (MSC service thread 1-1) Reading config : vfs:/content/CONNECTAdminGUI-4.4.war/WEB-INF/lib/primefaces-4.0.jar/META-INF/faces-config.xml
09:38:18,695 INFO  [org.hibernate.validator.util.Version] (MSC service thread 1-1) Hibernate Validator 4.2.0.Final
09:38:18,775 INFO  [org.apache.myfaces.util.ExternalSpecifications] (MSC service thread 1-1) MyFaces Bean Validation support enabled
09:38:18,961 INFO  [org.apache.myfaces.config.FacesConfigurator] (MSC service thread 1-1) Serialization provider : class org.apache.myfaces.shared_impl.util.serial.DefaultSerialFactory
09:38:18,964 INFO  [org.apache.myfaces.config.annotation.DefaultLifecycleProviderFactory] (MSC service thread 1-1) Using LifecycleProvider org.apache.myfaces.config.annotation.Tomcat7AnnotationLifecycleProvider
09:38:18,982 INFO  [org.primefaces.webapp.PostConstructApplicationEventListener] (MSC service thread 1-1) Running on PrimeFaces 4.0
09:38:18,983 INFO  [org.apache.myfaces.webapp.AbstractFacesInitializer] (MSC service thread 1-1) ServletContext initialized.
09:38:18,988 INFO  [org.apache.myfaces.webapp.WebConfigParamsLogger] (MSC service thread 1-1) Tomahawk jar not available. Autoscrolling, DetectJavascript, AddResourceClass and CheckExtensionsFilter are disabled now.
09:38:18,998 INFO  [org.apache.myfaces.webapp.WebConfigParamsLogger] (MSC service thread 1-1) Scanning for context init parameters not defined. It is not necessary to define them all into your web.xml, they are just provided here for informative purposes. To disable this messages set org.apache.myfaces.LOG_WEB_CONTEXT_PARAMS config param to 'false'
09:38:18,998 INFO  [org.apache.myfaces.webapp.WebConfigParamsLogger] (MSC service thread 1-1) No context init parameter 'javax.faces.RESOURCE_EXCLUDES' found, using default value '.class .jsp .jspx .properties .xhtml .groovy'.
09:38:18,999 INFO  [org.apache.myfaces.webapp.WebConfigParamsLogger] (MSC service thread 1-1) No context init parameter 'javax.faces.FULL_STATE_SAVING_VIEW_IDS' found.
09:38:19,000 INFO  [org.apache.myfaces.webapp.WebConfigParamsLogger] (MSC service thread 1-1) No context init parameter 'javax.faces.PARTIAL_STATE_SAVING' found, using default value 'true (false with 1.2 webapps)'.

Please see attached. For complete log.server.log
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

Naresh Subramanyan
Try with the deployed application name in the URL (CONNECTAdminGUI-4.5.0-SNAPSHOT or CONNECTAdminGUI-4.4 or  something like that.)

http://localhost:8080/<Deployed Application Name>


Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

richersoon
It is now accessible. Thank you a lot.

I am now in log in page, what is the default password indicated in the DBScripts/adminguidb/adminguidb.sql
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

Naresh Subramanyan
Its password :)-
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

richersoon
I was able to log in but I got another error:

14:45:44,681 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[default-host].[/CONNECTAdminGUI-4.4].[facesServlet]] (http--10.0.0.239-8080-6) Servlet.service() for servlet facesServlet threw exception: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Unknown column 'this_.serviceType' in 'field list'
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) [rt.jar:1.7.0_65]
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57) [rt.jar:1.7.0_65]
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) [rt.jar:1.7.0_65]
        at java.lang.reflect.Constructor.newInstance(Constructor.java:526) [rt.jar:1.7.0_65]
        at com.mysql.jdbc.Util.handleNewInstance(Util.java:406)
        at com.mysql.jdbc.Util.getInstance(Util.java:381)
        at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:1030)
        at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:956)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3558)
        at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:3490)
        at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1959)

Here's the complete log: server.log

Thanks for the assisstance.
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

Naresh Subramanyan
Looks like you don't have the latest DB event tables. If you are doing a binary install , then follow the steps "Create Database and Tables" from the below link.
https://connectopensource.atlassian.net/wiki/display/CONNECT4/Deploying+CONNECT+4.4+from+Binaries

Naresh
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

richersoon
I already did the "Create Database and Tables" but I error still occurs. Please help

Thanks,
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

Naresh Subramanyan
You will see that error if you don't have all the required columns in the event table. Make sure you have the "serviceType" field in the event table or you can drop/recreate the CONNECT databases again and try.

Thanks,
Naresh
CONNECT Product Team
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

richersoon
I already drop and create the database but the error still showing.

eventType is also there, inside the eventdb schema, it doesn't have any data in there.


Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

richersoon
In reply to this post by Naresh Subramanyan
The webservice test connection also success. I really don't know why it is giving that error, please help.
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

Naresh Subramanyan
What version of MySQL you are using?

Thanks,
Naresh
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

richersoon
I am using version MySQL version 5.6.19, running in Amazon RDS

Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

Naresh Subramanyan
Not sure why its not working, you can try the below options:
1. I don't see the default value set in the event.eventtime field, run the below script and try to bounce the application and see if it works
ALTER TABLE `eventdb`.`event`
CHANGE COLUMN `eventTime` `eventTime` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP ;

2. We use MySQL 5.1.42 in our test environment, may be you can try this version.
  protocol_version    10
  version                 5.1.42
  version_comment   MySQL Community Server (GPL)
  version_compile_machine i686
  version_compile_os      pc-linux-gnu                

Good Luck.

Thanks,
Naresh
Reply | Threaded
Open this post in threaded view
|

Re: Error in installing Connect in JBoss 7.1.1 - java.lang.ClassNotFoundException: org.primefaces.event.TabChangeEvent

richersoon
This is now working.

Many thank you. Godbless
12