Quantcast

Connect Validation Tests Failure

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Connect Validation Tests Failure

Reddy2015
Hi Team,

We are using Connect version 4.3 and facing below issues while doing validation test suits.

1) XPath issue in SOAP UI, attached screenshot for the same issue

com.eviware.soapui.impl.wsdl.teststeps.assertions.basic.XPathContainsAssertion@4ee5afe3
XPathContains assertion failed for path [declare namespace ns1='urn:hl7-org:v3';
                                //ns1:PRPA_IN201306UV02[1]/ns1:controlActProcess[1]/ns1:subject[1]/ns1:registrationEvent[1]/ns1:subject1[1]/ns1:patient[1]/ns1:patientPerson[1]/ns1:name[1]/ns1:given[1]] : Exception:Missing content for xpath [declare namespace ns1='urn:hl7-org:v3';
                                //ns1:PRPA_IN201306UV02[1]/ns1:controlActProcess[1]/ns1:subject[1]/ns1:registrationEvent[1]/ns1:subject1[1]/ns1:patient[1]/ns1:patientPerson[1]/ns1:name[1]/ns1:given[1]] in Response
com.eviware.soapui.impl.wsdl.teststeps.assertions.basic.XPathContainsAssertion@497e888c
XPathContains assertion failed for path [declare namespace ns1='urn:hl7-org:v3';
                                //ns1:PRPA_IN201306UV02[1]/ns1:controlActProcess[1]/ns1:subject[1]/ns1:registrationEvent[1]/ns1:subject1[1]/ns1:patient[1]/ns1:patientPerson[1]/ns1:name[1]/ns1:family[1]] : Exception:Missing content for xpath [declare namespace ns1='urn:hl7-org:v3';
                                //ns1:PRPA_IN201306UV02[1]/ns1:controlActProcess[1]/ns1:subject[1]/ns1:registrationEvent[1]/ns1:subject1[1]/ns1:patient[1]/ns1:patientPerson[1]/ns1:name[1]/ns1:family[1]] in Response

2. Problem writing SAAJ model to stream
   Attached server log

Soap_UI_Patient_Discovery.pngserver_error_log.txt

Please check and do the needful.

Thanks,
Suguna.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Connect Validation Tests Failure

Reddy2015
This issue has been resolved after copying the certificates (gateway.jks, cacerts.jks) to <glassfish_install_dir>/domain/domains/config.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Connect Validation Tests Failure

prasanna
Hi,
  Can you please let me know from which path you took certificates (gateway.jks, cacerts.jks) to copy into
<glassfish_install_dir>/domain/domains/config.

I copied the certs which are found in ValidationSuite/src folder but no luck. It's not working for me.

Can you please help me on this. Your quick help is much appreciated!!!

Thanks,
Prasanna
Loading...