Connect 4.6 with Glassfish - Build fail when performing ant install

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Connect 4.6 with Glassfish - Build fail when performing ant install

earla12
The mvn clean install appears to have worked fine, but when I attempt to perform the build for Glassfish (ant install), I receive the following build failure:

deploy.to.production:

-deploy.create.glassfish.password.file:
     [echo] deploy.glassfish.password.file.path: C:\Users\CONNEC~1\AppData\Local\Temp\glassfish669858296

-deploy.glassfish.asadmin:

deploy.glassfish.stop.server:
     [exec] CLI306 Warning - The server located at C:\glassfish3\glassfish\domains\domain1 is not running.
     [exec] Command stop-domain executed successfully.

deploy.nhinc.configuration.to.glassfish:
    [unjar] Expanding: C:\Users\ConnectAdmin\.m2\repository\org\connectopensource\Properties\4.6.0\Properties-4.6.0.jar;org\slf4j\slf4j-api\1.7.13\slf4j-api-1.7.13.jar;org\slf4j\slf4j-log4j12\1.7.13\slf4j-log4j12-1.7.13.jar into C:\glassfish3\glassfi
sh\domains\domain1\config\nhin

BUILD FAILED
C:\Program Files\Git\CONNECT46\Product\Install\build.xml:259: The following error occurred while executing this line:
C:\Program Files\Git\CONNECT46\Product\build.xml:28: The following error occurred while executing this line:
C:\Program Files\Git\CONNECT46\Product\Install\deploy.xml:263: Error while expanding C:\Users\ConnectAdmin\.m2\repository\org\connectopensource\Properties\4.6.0\Properties-4.6.0.jar;org\slf4j\slf4j-api\1.7.13\slf4j-api-1.7.13.jar;org\slf4j\slf4j-log4
j12\1.7.13\slf4j-log4j12-1.7.13.jar
java.io.FileNotFoundException: C:\Users\ConnectAdmin\.m2\repository\org\connectopensource\Properties\4.6.0\Properties-4.6.0.jar;org\slf4j\slf4j-api\1.7.13\slf4j-api-1.7.13.jar;org\slf4j\slf4j-log4j12\1.7.13\slf4j-log4j12-1.7.13.jar (The system cannot
 find the path specified)
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Connect 4.6 with Glassfish - Build fail when performing ant install

Minh
Administrator

Thank you for using our CONNECT product.  If you try to install Glassfish binary, you can download from <a href="https://connectopensource.atlassian.net/wiki/display/CONNECT4/4.6&#43;&#43;Binaries"> https://connectopensource.atlassian.net/wiki/display/CONNECT4/4.6++Binaries.  Otherwise, please use maven tool to build new ear.  The output should be \CONNECT\Product\Production\Deploy\glassfish\target.  

Starting from 4.6, we are no longer support glassfish testing. Please consider to use wildfly/Websphere/weblogic.

 

 

Minh-Hai Nguyen
CONNECT Product Team Member
Loading...