COONECT-5 WEBSERVICE ENDPOINTS ARE NOT VISIBLE IN JBOSS WILDFLY 8.2.1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

COONECT-5 WEBSERVICE ENDPOINTS ARE NOT VISIBLE IN JBOSS WILDFLY 8.2.1

chitender
we deployed the CONNECT EAR on JBOSS wildfly 8.2.1 which we compiled from 5.0.0_integration branch. we are using OpenJdk 1.8.

ear got deployed succesfully and the soap validation test got passed also. but when we are trying to view the available web service endpoints on JBOSS wildfly web console wunder runtime==>subsystems==>webservices, it is empty.

below is the server.log and standalone.xml file for reference.
server.log
standalone.xml

any advice on this would be appreciated.

Reply | Threaded
Open this post in threaded view
|

Re: COONECT-5 WEBSERVICE ENDPOINTS ARE NOT VISIBLE IN JBOSS WILDFLY 8.2.1

Minh
Administrator
Hi chitender,

Did you deploy CONNECT ear by dropping the ear into <wildfly_home>\standalone\deployments since I don't see the CONNECT EAR inside standalone.xml?  That can be one of reasons you don't see webservice endpoint in wildfly console.  

Here is another ways to deploy CONNECT.  
1. Use wildfly admin console to deploy manually.
2. command line like this "<wildfly_home>/bin/jboss-cli.bat -c --command="deploy <path to your connect ear>"

You should see something like this at the end in standalone.xml
<deployment name="CONNECT-JB7.ear" runtime-name="CONNECT-JB7.ear">
            <content sha1="065ca1878ed2b00499b56e4a7c7ed9b0896d4360"/>
        </deployment>

Hope this will help and thank you for using CONNECT Product.
Minh-Hai Nguyen
CONNECT Product Team Member