CONNECTDirect was working, now isn't

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

CONNECTDirect was working, now isn't

m.mall@isharemedical.com
I installed CONNECT with Direct 5.0 on a CENTOS 6 server.  I already have another service running on port 8080; so, I set port-offset="${jboss.socket.binding.port-offset:10} in the standalone.xml file so that it would run on port 8090 instead.  After this, I found that I also had to change the file, modules/system/layers/base/org/connectopensource/configuration/main/internalConnectionInfo.xml, to use port 8090 for all of the services, including the directconfig service.  The offset setting didn't seem to take care of this.

After restarting the server and launching standalone.sh, I went into the CONNECTAdminGUI and the menu options for Direct were present.  For several reasons, I needed to restart the server and the standalone.sh and it worked just fine after that for several restarts.  One time, however, I restarted the server and the standalone.sh and, since then, the Direct menu option is no longer there.  The following "Caused by" is displayed while standalone.sh is being executed.

Caused by: org.apache.cxf.transport.http.HTTPException: HTTP response '404: Not Found' when communicating with http://localhost:8090/CONNECTDirectConfig/ConfigurationService

I don't think I changed anything before restarting everything.  It was working and it just stopped working for some reason.  Anyway, I am running out of ideas for how to troubleshoot this short of stopping the other service that uses 8080 and setting everything to defaults.

From standalone.xml:

    <socket-binding-group name="standard-sockets" default-interface="public" port-offset="${jboss.socket.binding.port-offset:10}">
        <socket-binding name="management-http" interface="management" port="${jboss.management.http.port:9990}"/>
        <socket-binding name="management-https" interface="management" port="${jboss.management.https.port:9993}"/>
        <socket-binding name="ajp" port="${jboss.ajp.port:8009}"/>
        <socket-binding name="http" port="${jboss.http.port:8080}"/>
        <socket-binding name="https" port="${jboss.https.port:8443}"/>
        <socket-binding name="txn-recovery-environment" port="4712"/>
        <socket-binding name="txn-status-manager" port="4713"/>
        <socket-binding name="connect" port="8181"/>
        <outbound-socket-binding name="mail-smtp">
            <remote-destination host="localhost" port="25"/>
        </outbound-socket-binding>
    </socket-binding-group>

From internalConnectionInfo.xml:

            <businessService serviceKey="uddi:nhincnode:directconfig">
                <name xml:lang="en">directconfig</name>
                <bindingTemplates>
                    <bindingTemplate bindingKey="uddi:nhincnode:directconfig" serviceKey="uddi:nhincnode:directconfig">
                        <accessPoint useType="endPoint">http://localhost:8090/CONNECTDirectConfig/ConfigurationService</accessPoint>
                        <categoryBag>
                            <keyedReference tModelKey="CONNECT:adapter:apilevel" keyName="" keyValue="LEVEL_a0"/>
                        </categoryBag>
                    </bindingTemplate>
                </bindingTemplates>
                <categoryBag>
                    <keyedReference tModelKey="uddi:nhin:standard-servicenames" keyName="directconfig" keyValue="directconfig"/>
                </categoryBag>
            </businessService>

Reply | Threaded
Open this post in threaded view
|

Re: CONNECTDirect was working, now isn't

Minh
Administrator
Hi
The reasons why "Direct menu sometime appears intermittently after restarting the server" is due to the order on how CONNECT ear and Admingui initialize. Connect Ear needs to start up first so that it can register Direct service.  Once CONNECT ear is up, Admingui Servlet can communicate to check whether CONNECt has Direct service or not.  If it doesn't exist on the start up, it won't show Direct menu.  We will log the issue in our backlog and will prioritize in our next release.

Thank
Minh-Hai Nguyen
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|

Re: CONNECTDirect was working, now isn't

m.mall@isharemedical.com
Minh,

Thank you very much for your reply.  In the meantime, is there anything you can suggest to help to make this work?  Can I delay the start of the AdminGUI until the other services have started?  Is there a way to start it manually?
Reply | Threaded
Open this post in threaded view
|

Re: CONNECTDirect was working, now isn't

Minh
Administrator
You can try the following:
1. Go to Wildfly Admin console.
2. Make sure CONNECT with Direct is active.  
3. Disable Admingui.
4. Once it is done, enable AdminGUI again kick off AdminGUI servlet initialization.  

Thanks,
Minh-Hai Nguyen
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|

Re: CONNECTDirect was working, now isn't

m.mall@isharemedical.com
Thank you again for your reply.  That did work for me.

Is this an issue with certain releases, 5.0 in my case, or are there versions that don't have this issue?  Is there a release that is regarded as the "most stable"?


Thanks again,

Mike
Reply | Threaded
Open this post in threaded view
|

Re: CONNECTDirect was working, now isn't

Minh
Administrator
Hi Mike,
This has been known issue before.  Since there is work around solution, the priority for the ticket has been shuffle as we start to release new version.  

Thanks,
Minh-Hai Nguyen
CONNECT Product Team Member