CONNECT 4.7 - Install Issue

classic Classic list List threaded Threaded
20 messages Options
Reply | Threaded
Open this post in threaded view
|

CONNECT 4.7 - Install Issue

edsalvador
I did a NEW install of:
 - Wildfly 8.2.1
 - CONNECT 4.7 (Standard NOT Direct)
The install seemed to go OK.
I deployed CONNECT-JB7-4.7.0.ear.
Checked the server.log - No errors
I deployed CONNECTAdminGUI-4.7.0.war.
Checked the server.log - No errors
I ran http://localhost:8080/CONNECTAdminGUI-4.7.0
Received 404 not found error
Closed Wildfly
Tried to restart Wildfly - does not start - in continuous loop
Here is the server.log

server.log
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

Sovann Huynh
Administrator
Ed, try http://localhost:8080/CONNECTAdminGUI-4.7.0.war

Can I ask which federal agency you're supporting?
Sovann
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
This post was updated on .
In reply to this post by edsalvador
I already tried that.
But, I reinstalled and tried again using http://localhost:8080/CONNECTAdminGUI-4.7.0.war.
I still get the same 404 not found error.
Also, once this happens, Wildfly will not start again - it just goes into a continuous loop.
Here is the server.log when trying to run http://localhost:8080/CONNECTAdminGUI-4.7.0.war
server.log

And here is the server.log when trying to restart Wildfly:
server.log

Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
I tried CONNECT 4.6.
I have done a NEW install of  CONNECT 4.6.
I am still seeing the same issues.
I can install and deploy up until the Datasources without issue.
As soon as I deploy the .EAR file, I am unable to restart Wildfly 8.2.1.

Windows Server 2008 R2
Java 8
MySQL 5.1
Wildfly 8.2.1

Any insight you can provide is appreciated.

Thanks
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
I reinstalled CONNECT 4.7 using Java 7.
Checked server.log prior to deploying EAR file - no errors.

Deployed CONNECT-JB7-4.7.0.ear.
Checked server.log - no errors.

Exited Wildfly 8.2.1.
Checked server.log - SEVERAL ERRORS.
Here is the server.log:
server.log

*** Tried restarting Wildfly 8.2.1 - will not start - continuous startup run.

Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

Sovann Huynh
Administrator
Ed, I couldn't find anything helpful in the server log. Compare your WildFly setup to the instructions here:  https://connectopensource.atlassian.net/wiki/pages/viewpage.action?pageId=85852282
Sovann
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
I rechecked the CONNECT 4.7 install.
I could not see any issues.

Here is the standalone.xml:
standalone.xml

Here is the standalone.conf.bat:
standalone.bat
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

Tabassum
Administrator
Hi,
Can you deploy ConnectAdminGUI again and try to browse to this url: http://localhost:8080/CONNECTAdminGUI

Also,
As a general rule of thumb, once you deploy CONNECT.ear, try to run ValidationSuite to be sure your ear deployed without any errors/issues.

Thanks
Tabassum
(CONNECT Team Member)
Thanks
Tabassum
(CONNECT Product Team Member)
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
Thanks for your reply.
I did the following:
I deployed CONNECT-JB7-4.7.0.ear
I deployed CONNECTAdminGUI-4.7.0.war
I opened Firefox and went to - http://localhost:8080/CONNECTAdminGUI
I was able to login to the AdminGui screen.

However:
I logged out of the AdminGUI app.
I closed the browser.
I exited Wildfly 8.2.1.
I tried to start Wildfly 8.2.1 - it would not start - it just continuously runs in a loop.
Here is server.log
server.log

What do you suggest?
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

christophermay07
This post was updated on .
Hi Ed,

I've never seen an issue quite like this one before, so take the following with a grain of salt.

In one of the server logs you posted previously, I'm seeing some errors during server shutdown that look similar to the following:

ERROR [stderr] (xnio-file-watcher[Watcher for C:\wildfly-8.2.1.Final\standalone\tmp\vfs\deployment\deployment8b670ef52ec1ccfe\DocumentQuery_a0-4.7.0.war-e2e406e3fad3397a/]-0) at sun.nio.fs.AbstractWatchService.checkOpen(Unknown Source)

Honestly, I don't exactly know what to make of that error, but it leads me to believe this might be a symptom of a larger issue which is leaving the CONNECT deployment in an inconsistent state during server shutdown.  Whatever the root cause is, this error message is associated with a known bug from the wildfly-camel subcomponent version used in WildFly 8.2.x:

https://github.com/wildfly-extras/wildfly-camel/issues/345

Although it's not officially supported, I have previously deployed and tested a couple different versions of CONNECT on WildFly 9.0.2 successfully.  I can't say for sure that trying this will resolve your issue, but it may be worth a shot, especially since the install instructions for CONNECT on WildFly 8.x and 9.x should be nearly (if not completely) identical.

Best of luck getting past this problem!  If you come across any new errors or behavior, definitely post it along with any logs.

Regards,

Chris May
CONNECT Community Member
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
This post was updated on .
Chris,
Thanks for the reply.
I installed CONNECT 4.7 on Wildfly 9.0.2.
I deployed CONNECT-JB7-4.7.0.ear
I deployed CONNECTAdminGUI-4.7.0.war.
I was able to login to the ConnectAdminGUI.
I logged out of ConnectAdminGUI.
I exited Wildfly 9.0.2.
I tried to restart Wildfly 9.0.2 - it still did not restart.
However, there are NO ERRORS in the server.log.
There are WARN items.
Here is the server.log:
server.log


Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

Minh
Administrator
Hi,
I would suggest the following action:
1. Undeploy CONNECT (ear and AdminGUI).
2. clean up the wildfly temporary deployment folder  (C:\wildfly-8.2.1.Final\standalone\tmp)
3. Clean up Wildlfy deployment folder (C:\wildfly-8.2.1.Final\standalone\data\content)
4. Redeploy CONNECT. Make sure you can login Wildfly Admin Console (not CONNECT)
5. Run SoapUI VAlidation Suite to make sure everything pass.

Please let us know how it goes.  If it still posts the problem, please attach new server log.

Thanks,
Minh-Hai Nguyen
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
This post was updated on .
Thanks for your suggestions.
I did the following:
 - Undeployed Connect (EAR and AdminGUI)
 - Deleted \standalone\tmp folder
 - Deleted files in \standalone\data\content folder
 - Deployed CONNECT-JB7-4.7.0.ear
 - Deployed CONNECTAdminGUI-4.7.0.war
 - Logged into CONNECT Admin Console
 - Logged out of CONNECT Admin Console
 - Exited Wildfly
 - Tried to restart Wildfly - Wildfly would not start
Here is server.log:
server.log

Please let me know if you need any additional information.

Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
I rechecked the installation and found that I was using Java 7 JRE instead of Java 7 JDK.
I updated to Java 7 JDK.
I reinstalled CONNECT 4.7.
I am still getting the same issue restarting Wildfly.
Here is  the server.log:
server.log
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
I have reverted back to Wildfly 8.2.1.

Again, following the CONNECT 4.7 install instructions through Configure Data Sources works OK.
I can stop and restart Wildfly without issue.
The issues occur after deploying the EAR and/or WAR files.

Can you provide what changes are needed to the logging.properties file in Wildfly to better diagnose what is happening when the EAR file and/or WAR file are being deployed?
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

Sovann Huynh
Administrator
Hi Ed, in an effort to optimize our community support, we're trying to better understand our users and how they are using CONNECT. Can you please take a moment to answer the following questions:

1. What organization do you work for?
2. What federal agency do you support? N/A if none.
3. Which HIE do you support? N/A if none.
4. Briefly describe how you are using CONNECT (i.e., as a gateway to the eHealth Exchange)

Thanks for your cooperation!

Sovann
Sovann
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
This post was updated on .
I have been running many different scenarios with the installation of CONNECT 4.7 on Windows Server 2008 R2.
This is what I have thus far:
 - If I Deploy then Enable the EAR file (by itself) - I can restart Wildfly without issue
 - If I Deploy then Enable the WAR file (by itself)  - I can restart Wildfly without issue
 - If I Deploy then Enable the EAR file, then Deploy and Enable the WAR file -  I can run AdminGUI.
But, Wildfly will NOT restart. It (standalone.bat) continuously runs until I terminate it.

Here is the server.log
server.log

Any insight or suggestions would be appreciated.
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
This post was updated on .
To try to better diagnose this issue, I installed CONNECT 4.7 on JBOSS 7.1.1.
I followed the instructions here:
https://connectopensource.atlassian.net/wiki/pages/viewpage.action?pageId=85852278\

Unfortunately, I am getting the same results as on Wildfly.
I am able to install up to and including Configure Data Sources without issue.
After I deploy and enable the EAR file and the WAR file, I am able to start AdminGUI.
But, I am not able to restart JBOSS 7.1.1.
It (standalone.bat) continues to run until I terminate it.
Here is the server.log
server.log
And also the boot.log
boot.log

Any insights or suggestions would be appreciated.
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
I may have found the solution.
In standalone.xml:
        <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.1">
            <deployment-scanner path="deployments" relative-to="jboss.server.base.dir" scan-interval="5000" deployment-timeout="1000" />
        </subsystem>

I added "deployment-timeout="1000" and it now seems to work. I can restart JBOSS 7.1.1 after deploying the EAR file and WAR file.

I will now try with Wildfly 8.2.1.
Reply | Threaded
Open this post in threaded view
|

Re: CONNECT 4.7 - Install Issue

edsalvador
Wildfly 8.2.1 will now restart after deploying the EAR file and the WAR file.
It (standalone.bat) was and is  taking a very long time to start.
I will now move on to validation and testing.