CONNECT 4.6/GF 3.1.2.2 install/testing problem

classic Classic list List threaded Threaded
25 messages Options
12
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
I have been able to get GF 3.1.2.2 and CONNECT 4.6 installed and (i hope) configured. GF info When I go through the "Test the Installation" steps, when running g1 and g0 test suites I get the following errors in SoapUI: Tue May 10 16:26:49 UTC 2016:ERROR:An error occurred [No such property: org for class: Script1], see error log for details Tue May 10 16:26:49 UTC 2016:ERROR:An error occurred [No match found], see error log for details Tue May 10 16:26:49 UTC 2016:ERROR:An error occurred [startup failed: Script3.groovy: 1: expecting '}', found '' @ line 1, column 850. alue("PassThruOn", "false"); } ^ org.codehaus.groovy.syntax.SyntaxException: expecting '}', found '' @ line 1, column 850. at org.codehaus.groovy.antlr.AntlrParserPlugin.transformCSTIntoAST(AntlrParserPlugin.java:140) at org.codehaus.groovy.antlr.AntlrParserPlugin.parseCST(AntlrParserPlugin.java:108) at org.codehaus.groovy.control.SourceUnit.parse(SourceUnit.java:236) at org.codehaus.groovy.control.CompilationUnit$1.call(CompilationUnit.java:162) at org.codehaus.groovy.control.CompilationUnit.applyToSourceUnits(CompilationUnit.java:912) at org.codehaus.groovy.control.CompilationUnit.doPhaseOperation(CompilationUnit.java:574) at org.codehaus.groovy.control.CompilationUnit.processPhaseOperations(CompilationUnit.java:550) at org.codehaus.groovy.control.CompilationUnit.compile(CompilationUnit.java:527) at groovy.lang.GroovyClassLoader.doParseClass(GroovyClassLoader.java:279) at groovy.lang.GroovyClassLoader.parseClass(GroovyClassLoader.java:258) at groovy.lang.GroovyShell.parseClass(GroovyShell.java:613) at groovy.lang.GroovyShell.parse(GroovyShell.java:625) at groovy.lang.GroovyShell.parse(GroovyShell.java:652) at groovy.lang.GroovyShell.parse(GroovyShell.java:643) at com.eviware.soapui.support.scripting.groovy.SoapUIGroovyScriptEngine.compile(SoapUIGroovyScriptEngine.java:138) at com.eviware.soapui.support.scripting.groovy.SoapUIGroovyScriptEngine.run(SoapUIGroovyScriptEngine.java:89) at com.eviware.soapui.impl.wsdl.teststeps.WsdlGroovyScriptTestStep.run(WsdlGroovyScriptTestStep.java:141) at com.eviware.soapui.impl.wsdl.support.AbstractTestCaseRunner.runTestStep(AbstractTestCaseRunner.java:211) at com.eviware.soapui.impl.wsdl.testcase.WsdlTestCaseRunner.runCurrentTestStep(WsdlTestCaseRunner.java:47) at com.eviware.soapui.impl.wsdl.support.AbstractTestCaseRunner.internalRun(AbstractTestCaseRunner.java:138) at com.eviware.soapui.impl.wsdl.support.AbstractTestCaseRunner.internalRun(AbstractTestCaseRunner.java:46) at com.eviware.soapui.impl.wsdl.support.AbstractTestRunner.run(AbstractTestRunner.java:129) at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) at java.util.concurrent.FutureTask.run(Unknown Source) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source) Caused by: Script3.groovy:1:850: expecting '}', found '' at groovyjarjarantlr.Parser.match(Parser.java:211) at org.codehaus.groovy.antlr.parser.GroovyRecognizer.openBlock(GroovyRecognizer.java:8317) at org.codehaus.groovy.antlr.parser.GroovyRecognizer.compoundStatement(GroovyRecognizer.java:7518) at org.codehaus.groovy.antlr.parser.GroovyRecognizer.compatibleBodyStatement(GroovyRecognizer.java:8963) at org.codehaus.groovy.antlr.parser.GroovyRecognizer.statement(GroovyRecognizer.java:899) at org.codehaus.groovy.antlr.parser.GroovyRecognizer.compilationUnit(GroovyRecognizer.java:757) at org.codehaus.groovy.antlr.AntlrParserPlugin.transformCSTIntoAST(AntlrParserPlugin.java:131) ... 26 more 1 error ], see error log for details Tue May 10 16:26:49 UTC 2016:ERROR:An error occurred [No such property: org for class: Script1], see error log for details error log within SoapUI: Tue May 10 18:00:43 UTC 2016:ERROR:groovy.lang.MissingPropertyException: No such property: org for class: Script1 excerpt from the server.log. This is the first error I come across. Caused by: org.apache.ws.security.WSSecurityException: General security error (Cannot load the resource saml.properties) Do I need to go through the "Supplemental Instructions" before I can run the SoapUI ConnectValidation tests? Thanks for your time and attention, Brian
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: CONNECT 4.6/GF 3.1.2.2 install/testing problem

Sovann Huynh
Administrator
Hi Brian,

Have you set the GatewayPropDir project-level property in SoapUI? It should be an absolute path to your CONNECT properties directory.

Sovann
Sovann
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
Yes, at the Project level in SoapUI: GatewayPropDir Setting
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

Minh
Administrator

Hi Brian,

 

Based on the error, it seems the system can not load saml.properties. Can you check to see whether you have that file inside $glassfish_home/domains/domain1/config/nhin?  Also, make sure that you can open without prompt the password.  When someone create the domain and you create subfolder, the window causes some weird permission issue.  Please make sure that folder has correct permission.

 

If possible, can you please provide server log?

 

 

Thanks,

 

Minh Nguyen

Connect Product Team

Minh-Hai Nguyen
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
I do have the saml.properties in the C:\glassfish-3.1.2.2-ml\glassfish3\glassfish\domains\domain1\config\nhin directory.

I am able to open it without any password prompt.

Here is my server.log file:


server.log
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

Sovann Huynh
Administrator
A couple things:

It looks like there are some syntax errors in the setup scripts in your SoapUI tests. Have you modified them in any way?

The security exceptions seem to be occurring because saml.properties can't be opened.  Can you modify the permissions on that file?
Sovann
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

Minh
Administrator
In reply to this post by sc000ter

Hi Brian,

 

Inside the folder $glassfish_home/../nhin/, can you please modify the following files as bellows:

·        Signature.properties:

o   org.apache.ws.security.crypto.merlin.file=<absolute path>/gateway.jks

·        truststore.properties:

o   org.apache.ws.security.crypto.merlin.file=<absolute path>/cacerts.jks

Restarting the server and try again. If possible, can you capture and send to us your server start up log?

Thank,

 

Minh-Hai Nguyen
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
In reply to this post by Sovann Huynh
I did inspect the security permissions and gave USERS full control of the file.  
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
In reply to this post by Minh
mm,

I made the changes to the two files you indicated.  

Stopped and restarted the server.

I'm uploading the first of several server log files.  I have 13 additional log files as well as server.log.


server.log_2016-05-11T10-56-03

Thanks,
Brian
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
In reply to this post by Sovann Huynh
I have not modified the soapUI setup scripts.  I just followed the instructions to import into SoapUI.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
In reply to this post by Minh
Mn,

I have adjusted the security permissions on the domain1 including all files and sub folders so that system USERS group has full control.

I have restarted the server and soapUI and sill get failing tests.

Thanks,
Brian
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

Sovann Huynh
Administrator
Just confirming, when you deployed the CONNECT  ear on GlassFish, did you specify the nhin directory in the library?
Sovann
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
Yes, when I deployed the ear I used the following value for the "Libraries" text box:
C:\glassfish-3.1.2.2-ml\glassfish3\glassfish\domains\domain1\config\nhin

However, when I go view the application's properties, the libraries entry is empty:
Connect properties
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
In reply to this post by Sovann Huynh
I was able to undeploy and redeploy CONNECT and got the libraries entry in:


I also have copied the FileUtils and mysql-connector jar files to the following places within soapUI:




Thanks for all your help,
Brian
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

Sovann Huynh
Administrator
That's great. Are your tests passing now?
Sovann
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

Minh
Administrator
In reply to this post by sc000ter

Hi Brian,

 

Nice work J.  Glad it works for you. Since we don’t officially support glassfish server starting from 4.6, please consider to user wildfly (8.2.1.Final) or other servers (WAS,weblogic) for your future upgrade.

 

Thanks,

Minh-Hai Nguyen
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
In reply to this post by Sovann Huynh
No my tests are still failing.

I'm wiping out the validation suite stuff and re-copying it from the connect source zip file.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
In reply to this post by Minh
My tests are still failing with the following:
Tue May 17 15:18:25 UTC 2016:ERROR:groovy.lang.MissingPropertyException: No such property: org for class: Script1

I have followed all the advice in this thread:
http://forums.connectopensource.org/CONNECT-4-3-Validation-Suite-Failing-td7579649.html

and I am still getting that error
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

Sovann Huynh
Administrator
We've made progress. I think we can ignore that error for now.

Can you tell us which test cases are failing?

Can you re-run the following database scripts in CONNECT\Product\DBScripts\nhincdb:

dropall.sql
nhincdb.sql
populateTestData.sql

And then test again?
Sovann
CONNECT Product Team Member
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: CONNECT 4.6/GF 3.1.2.2 install/testing problem

sc000ter
All tests in g1 and g0 are failing.

I have re-run the .sql scripts, closed SoapUI, opened SoapUI and re-run g1 and g0.  Still failing with the same error.

12
Loading...